MySheerID User Management Error
Incident Report for SheerID
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 20:23 UTC
Update
We are continuing to investigate this issue.
Posted Apr 11, 2023 - 20:23 UTC
Investigating
An issue has been discovered with MySheerID (https://my.sheerid.com) that is affecting users who are attempting to reset their password, have an expired password, or are attempting to invite new users who must create a password. This issue may prevent you from performing password-related account updates. All other MySheerID services are performing as expected.

A cause has been identified and resolution is underway.
Posted Apr 11, 2023 - 18:34 UTC