My.SheerID.com is down
Incident Report for SheerID
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 22:06 UTC
Investigating
We are currently investigating this issue.
Posted Apr 03, 2023 - 21:51 UTC
This incident affected: Web services (MySheerID).