Student data source: temporary disruption
Incident Report for SheerID
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 21:24 UTC
Investigating
A data source supporting Student Segments is experiencing issues. All other services, including our document review service and other data providers, will be performing as expected.
Posted Jun 13, 2023 - 19:55 UTC
This incident affected: Student programs.