Increased API latency
Incident Report for SheerID
Resolved
This incident has been resolved.
Posted Nov 01, 2023 - 09:07 UTC
Update
We are continuing to investigate this issue.
Posted Nov 01, 2023 - 08:17 UTC
Investigating
We are investigating reports of increased latency and will provide updates as we resolve the issue. Some customers may notice delays when submitting verification requests.
Posted Nov 01, 2023 - 07:30 UTC
This incident affected: Web services (API) and Student programs, Military programs, First Responder programs, Faculty programs, Medical programs.