Student data source: temporary disruption
Incident Report for SheerID
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 21:08 UTC
Monitoring
A data source supporting Student Segments is experiencing issues. All other services, including our document review service and other data providers, will be performing as expected.
Posted Jul 21, 2023 - 19:18 UTC
This incident affected: Student programs.