MySheerID Customer Service Search

Incident Report for SheerID

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 22:04 UTC

Identified

There is partial degradation to the MySheerID Customer Service Search functionality where it may return an error. We've identified the issue and are working towards resolution.
Posted Aug 20, 2025 - 20:45 UTC
This incident affected: Web services (MySheerID).